[SOLVED] No textures on iPads, iPhones?

I’m working on a project for a major vehicle manufacturer. It’s all NDA so I can’t load a link.

Everything works great on desktop browsers, and android, but on ipads, iphones, the textures aren’t appearing on the geometry.

Is this a known issue with ipads, iphones that has a workaround or is this something probably related to my implementation? The geometry is clean polys with one uv map and a texture assigned to the diffuse. Not doing anything fancy.

How large textures are?
Can you create alternative project with similar setup, using alternative similar media but that doesn’t falls under NDA. So you could share it so we can replicate the issue?

I might have to do that. It’s a weird issue, looking closer… it’s just some of the geometry on the vehicle, but it’s consistent in that it’s geometry where I baked the textures out from the original Cinema 4D file and then re-baked them in Modo to a different set of UVs.

Other parts of the vehicles have normal, transparent, and diffuse maps that are showing up, it’s just the geometry mentioned above where the diffuse maps aren’t showing up. At the end of the day it’s just .obj files each with one UV set and 1024 x 1024 jpegs as the textures though. Pretty standard stuff.

I’m going to investigate today some more, if I just can’t figure it out I’ll post something public.


Eh…my bad. I forgot to change the baked textures from CMYK to RGB when I was creating them. It’s all good now.

It was a good bug to have though since by converting the images correctly it shaved a meg off the apps footprint.

So problem solved?
In computer graphics, RGB is - a must. CMYK is used for print and is totally different way of storing colour, I’m surprised it even worked on some platforms :slight_smile:

Me too. Android and Desktop were apparently ok with it.

I was surprised a little that the CMYK colors baked out of Cinema 4D and then re-baked through Modo without me even noticing or there being any graphic goofiness.