[SOLVED] Multiplayer not working

Hey, I tried to use the live multiplayer tutorial and added it step by step (other than changing the object used for player and other which still share the same properties as the ones in the tutorial example), made sure the server url was right, and made sure everything was the same, and upon publishing it and opening it in my browser, it loaded right, then when I opened another instance, it just loaded like it would if it was singleplayer. No other balls were on the map. Can someone help me figure out what is wrong?

Project: PlayCanvas 3D HTML5 Game Engine (Look for network.js in “/”)

Glitch.me server: Glitch :・゚✧

I don’t know if it just isn’t going onto the same server or something, but please let me know what it is and what to do!

Hi @Cryptonaph! I can’t find network.js in your project.

That’s odd, it should be there, I have it open right now, could there be some reason it isn’t saving?

I’m not sure what could be the reason. Below all I can see.

That’s odd, should look like this.

Are you sure you shared the right project?

Yeah, do I maybe have to put it all in the master branch? I hit publish and the map looks like it does in the recent version but I suppose it didn’t save right?

I thought I figured out the problem but I was wrong. Anyways, I tried forking the project and it went back days worth of checkpoints for some reason, even though the latest checkpoint was today. Not sure what is wrong.

Ah, if you do it in another branch then that’s why I can’t see it.

So should I merge them?

I think so. Sorry, I didn’t use it myself yet.

After merging them, no new changes. However now you should be able to access the network.js script.

Also I probably should mention that the “Player Joined” console log in glitch.me isn’t going off at all when you join.

Wait, I may have found the problem, give me one second.

Nevermind, I still do not have the solution.

I’ve narrowed it down that it isn’t anything to do with the cameraMovement script, positionSync, movement, rigidbody-extensions, or teleportable, which are all needed scripts.

I need to compare your project with the multiplayer tutorial. I will do this as soon I have time. Did you already try to do this?


I tried your project and for me the multiplayer part is working.

Sorry for the (very) late response on this post, but yes, I had managed to fix it solely because I had a multiplayer test fork that worked a little and so I copied some files over and it worked, thanks!