[SOLVED] Morph target names are lost when importing GLB through editor

The ability to import GLBs into the editor is a very welcome addition, but the bug I’ve found is that morph target names are lost in the process making it pretty much impossible to use blendshape animations.

I’m testing on the Ready Player Me avatars and morph target work great when I load GLB as an external asset, but if I import it into the editor, blend shape names are empty making it unusable.

1 Like


In the short term, if you want to import them into the editor as binaries, rename the file to something.glb.bin and you can load them as an ‘external’ asset via Loading glTF GLBs | Learn PlayCanvas

Hi @bezrodnyigor ,

Sorry about this. We have a fix which should be released within the next week or so.


Please note that morph target names are stored on mesh in gltf, not on the animations. Since we split model and animation into two different files, this means the imported animation file won’t contain the morph target names, but the referenced mesh will.

Not sure, will this be an issue for you @bezrodnyigor?

It should not be an issue here. Both mesh and animation glb files are generated from a single source file, and so the order of morph targets would be the same in the mesh as well as animation. Engine would internally match those using this order in case the animation file does not have the target names.

Thank you for the information.

I’ve bypassed the issue by loading the file from external server, everything works good there.
As for animations - I’m animating the character procedurally (sound based lip sync and stuff like that), so that wouldn’t be an issue in my workflow.

The fix has now been released.

Tried it yesterday, works now.
Thank you!