[SOLVED] Missing FBX Textures


I’m working on a project with fbx files but when I import the fbx files, the materials are correctly created but they are missing their textures.

Do I have to manually assign each texture to the material, or is there a way for PlayCanvas to do it automatically upon import?

Thanks very much!


By clicking the gear icon on the left to access settings, you can try selecting the check under “Asset Tasks” for “Preserve material mappings”

Then try importing the model again.

Thanks @eproasim for your response! These are the settings of the project

make sure you embed textures in your dcc tool

Select the ‘Embed Media’ option in the FBX exporter panel. This packages the scene’s textures in the exported FBX. This preserves material to textures links during import into PlayCanvas. Otherwise, you must upload all scene textures separately and relink all textures to materials


Embedding Textures

Embedded Textures make importing much easier.

The Blender COLLADA exporter does not have the ability to embed textures into the exported model file.

The 2.71 release of Blender features a revamped FBX export module that enables multiple embedded textures directly from Blender. First make sure the object is rendered correctly within Blender. When exporting to FBX, set the ‘Path Mode’ to Copy and check the ‘Embed Textures’ box.

Alternatively, use the Autodesk FBX Converter to convert an export from Blender into one with embedded media. Just open the file in the FBX Converter and re-save with the Embedded Media checkbox set.


@grzesiekmq Thanks so much, we got it working with your help! :pray:

1 Like