[SOLVED] Mipmapping not working for non-power of two texture

How I can correct the ‘image’?
These artifacts with bricks

What are you expecting them to look like and what are the artifacts that you are seeing?

like this

also https://playcanvas.com/editor/scene/1091158
here u see when you zoomed out there are artifacts but when zoom in image is ok

You will want to reduce the tiling on your material by a lot since you’re repeating the texture. Try setting the tiling to 0.1x0.1


ok thanks!

This seems to be a bug in the engine. Read more here:

A workaround is to enable Textures POT in the Asset Tasks section of Settings and reupload the texture. Because right now, the engine can only mipmap power-of-two textures, even with WebGL 2.

1 Like