[SOLVED] Materials are broken suddenly

In editor

In launch

Phong material, tried to disable everything, but it’s an issue with PlayCanvas engine. Literally didn’t change anything. Also old projects are broken too.

Please allow us to use older version of engine. Previous and one previous is not enough. We can’t go release because of those small issues.

It’s possibly an another instance of the same issue. We have a fix and we’ll release it sometimes early next week.

Are you able to test against the current main branch of the engine that contains the fix?

If this does not fix it, are you able to create a small reproducible project?

  • Latest version doesn’t solve the problem.
  • I can’t create reproducible version because when I clone materials into another project it’s solved. But I forked project and give you access if needed.

Who should I add to the project?

Could you please describe the problem in those two screenshots. They’re different enough that I’m not sure which of those differences is the problem to look at. And give us some details of what you’re doing there, what material types for example, and what does not work specifically.

I created cheap shadows with plane and it has a material, and it has tint black color with alpha channel.

For some reason suddenly those materials started to show up as purple tinted colors. In editor it looks correct but on run-time it’s not.

Even in empty scene without any additional script they turn into that purple colored material.
Maybe I’m missing something…

When I tested it with old version engine (8 May), it works as expected with same scene files.

Ok that is interesting, and something we can likely fix. Could you please create an example with just this one element that goes purple.

If you could also create an issue here for tracking: Issues · playcanvas/engine · GitHub

@commention if you publish the build and run the build, does it render correctly?

Wow, that’s super interesting, it’s not happening on build, now that’s weird.

Ok, so its likely to be the same issue as this thread with alpha transparency in the launch tab.

Can you still post a public project of the issue for the team to verify please?


The fix is now deployed @commention - apologies for any inconvenience! On the plus side, we now have WebGPU working in the Editor (behind a flag). :smile:

Let us know if you have any further problems related to this.