[SOLVED] Issue with scripts assets importing

Hello :slight_smile: !
there is an issue with scripts importing inside playcanvas. If I drag multiple scripts at the same time inside the project not all of them seems to be loaded inside the project.

Here is a debug project where I managed to reproduce the issue PlayCanvas | HTML5 Game Engine

In this project I dragged five scripts at the same time

But only four of them appear in the script loading order.

This issue does’nt happen when I drag the scripts one by one.

I tried as a temporary fix to mess up with the preload button but at some point the editor trigger this error.

editor.js:10913 Operation was rejected ([object Object]). Trying to rollback change locally.
Doc._onMessage	@	editor.js:10913
Connection.handleMessage	@	editor.js:10287
socket.onmessage	@	editor.js:10188
connection.socket.onmessage	@	editor.js:14673

And I cannot check or uncheck the preload button at all after that.

Maybe something not saving properly inside the scene Json?

[EDIT] this cause the script not behing found in playmode

script 'dummyScriptTwo' is not found, awaiting it to be added to registry
create @ playcanvas-stable.dbg.js:22437

Thanks @Acharton,

We’re taking a look at the project and the issue.

1 Like

Hi @Acharton,

We deployed a fix that should resolve some scripts not being added to the script order correctly when you drag multiple in the asset panel. Please let us know if you have any problems.

1 Like

Every thing seems to work thanks!