[SOLVED] Importing model not working correctly since server restart

@dave @moka @will I am hoping that you might be able to help me. I have a project that the client reviewed and we needed to update some models. I tried importing the new .dae files, and the JSON and DAE come in but the mesh instances and materials that were exported are no longer recognized. I thought perhaps it was something I was missing in blender, but I imported some old models that worked on earlier projects into a new project and the same problem exists for them. I am under a tight deadline, so any help would be greatly appreciated.

Here is the link:

https://playcanvas.com/project/602298/overview/dae-mesh-instances-not-importing https://playcanvas.com/project/602298/overview/dae-mesh-instances-not-importing

So I stepped through the model with code and the mesh instances are there, but the editor is no longer recognizing them. I have for the interest of time added the materials via code, but it would be great to fix the editor so that it recognizes and displays them again accordingly. Thanks!


It looks like you have no materials assigned to any of the meshes in your DAE source. Can you assign a material to at least one of the meshes and re-import?

I’ll try. I guess my question is why has it worked with these same .daes in the past?

@dave that definitely worked. Thanks so much. I am curious, why would it have worked for the example I posted in another project?

@dave I see that you have marked it SOLVED, which in a sense it has been, but the underlying question of why did it work with these model up until 2 days ago, never got answered by you. Would you have any thoughts on why it was working just fine until then?

We’ll look into whether anything has changed regarding this behavior but your issue here seems to be resolved?

In terms of how to proceed, yes. I will just be more clear about deliverables with my modeler.

@dave BTW, what the behavior of the editor had been doing in the past, was that if a material was not imported in the .dae, it would display all the mesh instances, but the reference would be empty.