[SOLVED] I got a CORS error after updating from PlayCanvas v1.29.0 to v1.30.0

I tried changing the version of PlayCanvas from v1.29.0 to v1.30.0.
In v1.29.0, the model was displayed without any problem, but in v1.30.0, an error occurs and the model cannot be loaded.

OK : PlayCanvas v1.29.0 sample:

NG : PlayCanvas v1.30.0 sample:

Uncaught DOMException: Failed to execute 'texImage2D' on 'WebGL2RenderingContext': The image element contains cross-origin data, and may not be loaded.
    at GraphicsDevice.uploadTexture (https://cx20.github.io/gltf-test/libs/playcanvas/v1.30.0/playcanvas-latest.js:50175:10)
    at GraphicsDevice.setTexture (https://cx20.github.io/gltf-test/libs/playcanvas/v1.30.0/playcanvas-latest.js:50330:11)
    at GraphicsDevice.draw (https://cx20.github.io/gltf-test/libs/playcanvas/v1.30.0/playcanvas-latest.js:50415:11)
    at ForwardRenderer.drawInstance (https://cx20.github.io/gltf-test/libs/playcanvas/v1.30.0/playcanvas-latest.js:11971:12)
    at ForwardRenderer.renderForward (https://cx20.github.io/gltf-test/libs/playcanvas/v1.30.0/playcanvas-latest.js:12427:17)
    at ForwardRenderer.renderComposition (https://cx20.github.io/gltf-test/libs/playcanvas/v1.30.0/playcanvas-latest.js:13139:11)
    at Application.render (https://cx20.github.io/gltf-test/libs/playcanvas/v1.30.0/playcanvas-latest.js:46727:18)
    at https://cx20.github.io/gltf-test/libs/playcanvas/v1.30.0/playcanvas-latest.js:47308:17

Is this a mistake in usage?
I would be grateful if anyone could give me some advice.

I suspect this was the cause of the issue: https://github.com/playcanvas/engine/pull/2243/files

I’ve tested the 1.30.0 sample against master (https://code.playcanvas.com/playcanvas-latest.js) and it looks good. I think we are due to release 1.30.1 sometime this week with the fix in.

1 Like

Thank you very much. I have confirmed that the problem has been resolved with the latest version.

OK : PlayCanvas v1.31.0-dev sample

Can you try again? We just deployed v1.31.0.

1 Like

Thanks! I have confirmed that the latest version works without problems.

OK : PlayCanvas v1.31.0 sample