[SOLVED] glTF model won't load at mobile

Good morning guys,

I have a model that need to be loaded from a server. At computers and notebooks it works perfectly, but at mobile devices it simply wont load.

Above is a print of mobile debug. The pencil lines are hiding my own console.log()

  • Android 5.1.1
  • Mozilla Firefox 61.0

OBS: Other androids and Chrome Browser shows the same error

after testing with a model that works on both the computer and the mobile, I discovered that the difference is here:

But I still do not know how to solve

Are you running from playcanvas.com? Or serving your project from your own server?

Running from playcanvas.
The stranger thing is that runnning from editor, the model load but not the texture

Now from the built version, the model doesn’t even load

On computer works great, but at mobile these problems occurs.
Another information: Changing the “24.json” to 25, 26, or 27, the player returns the other models the loads correctly at computer and mobile

Is it possible to have the URL to the 24.json model?

The 24.json is a bunch of information that have also the link of a GLB file

I had to change the project, build, and model links that I had posted because the server that returned the information changed.

The model doesn’t render correctly on some Android devices because the GLB file has a mesh with 88,117 vertices. This means that the mesh’s index buffer has indices that exceed 65535 and so cannot fit in 16-bit indices. Unfortunately, some older Android devices (like those with the Mali-400 MP GPU) do not support 32-bit indices and fail to render the mesh.

1 Like

I’ve created this issue on GitHub to address this:

1 Like

Thanks, that just give me a way to solve this

@will use https://github.com/AnalyticalGraphicsInc/gltf-pipeline/tree/2.0
Converting a glTF to Draco glTF, Drag to viewer wont load:

@Sanonz Can you share the glTF file?

bmw model: https://raw.githubusercontent.com/sanonz/store/master/bmw.zip

Looks OK to me, @Sanonz :

Are you using the latest version of the loader?

use output/draco.gltf and output/draco.bin, it’s looks OK, but there are a bunch of errors on the console.


It’s OK…

1 Like