[SOLVED] GLB File Not Appearing and Converted FBX File has no Texture


I have created a ship model I would like to use for a game, but the program I used would only let me export in a GLB file format. Once I uploaded the GLB file into the editor, I couldn’t add it into the hierarchy. I found out that Playcanvas doesn’t support GLB files, so I used some online tools to convert it into FBX files. Once I added those in, the FBX files were able to add into the hierarchy, but they had no texture. I also tried with a JSON file, but that didn’t work either. I have found that GLB files can be loaded into Playcanvas with scripts, but I want to be able to see the ship in the editor so I can move it around it easier. Can anybody tell me a way to load in GLB files into Playcanvas without scripts, or maybe converting GLB to FBX with the textures? The GLB, FBX and JSON files are all in the editor link above.

Hi @InfinityLight! Maybe you can upload the textures manually and also add them manually to the material?

@Albertos I don’t know how I can get the textures separately from the GLB file.

It’s strange but I can open the GLB file in Playcanvas viewer.

I imported the GLB into Blender and I can see the color. So I exported from Blender an FBX making sure to carry the material colors along with. Imported into PC and get he same gray. There must be something I am missing.

Hey @Tirk182,

What steps did you take to display the texture/material in blender? I’m investigating this issue but no material/texture is showing up for me there.

@poliveira I imported into Blender(ship.glb). Then I select the shader to the right. Screen shots below.


Also note that I do not see a lot in the way of materials in the tree view. Something is fundamentally wrong, I think.

1 Like

There is no texture for this model, the colors come from Vertex Colors. By default, the material when importing the model does not have Vertex Colors enabled. You can easily enable them by heading over to this section in the material inspector:


@poliveira Thank you! It works now!

1 Like

@poliveira Thanks for this find. I had not thought of that solution. This is the something that I totally missed. :+1:

1 Like