[SOLVED] FBX import with animation causing 90° rotation to model mesh. Seeing a .json file change/bug?


I’m having trouble with importing FBX files with animation. The models import and place correctly but when the animations are attached the models rotate 90° but the animation paths do not rotate with the model.

I think it might be a change/bug in the import code for the animation json file. Testing with FBX files that worked in earlier projects produces the same error. But the files still work in projects that imported them a while ago (Spring 2020).

Downloading the animation json for each shows the working version has a -90 in the “r” value compared to the new broken one. I would test the simple fix of added the missing -90 to the json but can’t edit the file and re-uploading the fixed json file can’t be selected as the animation for the model.

Any ideas?


Hi @Chris_Pusateri,

That seems like a bug or change introduced in the animation importer. There were some changes from what I remember a couple of months ago in the importer.

Calling @yaustar to assign this to the Playcanvas team. Would you care to submit an issue in the editor repo as well?

Thanks @Chris_Pusateri, we are looking into this as soon as we can

You might be able to get away to create a new animation JSON by using Leonidas’ workaround here [SOLVED] Merging projects

I dont think that really a bug depending if im wrong if the model is just sideways once spawned. Im pretty sure thats normal

A fix is being tested on our dev server. I expect it will be deployed to production this evening.

Awesome! Thank you for the quick replies/testing/fix.

I did continue testing last night and found that like this issue: animated-fbx-model-importing-with-empty-invisible-mesh.
I could re-import the fbx files into 3DMax, export again to FBX and that file would import and animate correctly. Kind of a pain to do with lots of models/animations but at least it is a work around if someone is stuck and needs the import to work right now.

Thanks All

1 Like

Something changed… maybe not a bug per se but the same fbx file that worked before does not work now. That and I have exported/imported tons of models with and without animation and this first time I’ve had the issue with model rotation for entities with animations attached.

Looks like the Canvas guys may have a fix in the works so all’s well that ends well…or something like that.

thanks for taking a look.

Hi, I was able to re-import the fbx file into 3DMax and then export again to FBX… that file imported and animated correctly.

A fix for this has been released!


Awesome! I have tested and the animation imports are working again. Thank you.