[SOLVED] FBX import from Blender trouble and flat-shading


#1

https://playcanvas.com/project/496457/overview/sputnik1

I’ve just created simple UV Sphere in Blender and exported to .fbx format (pic 1)
And dropped it into PlayCanvas scene. now it looks like pic 2
First question: Why does it flat shaded? I didn’t do any actions to do it flat, I thought it’s should be smooth shaded by default, doesn’t it? It’s surprising :slight_smile: May be because vertices are duplicated

Then, I’ve attached custom material to this mesh with diffuse map (like Earth). Just flat diffuse color works good, but texture is going wrong (pic 3, left is flat color, right is texture). Well, second question is, how to make it work?

Finally, I want to achieve flat shading effect, but with texture on the sphere. Should I use Blender tools for make specific texture or smth like this?




#2

Having similar problems my end. I’m getting my models in fine, but have no texture what so ever either. Might try baking the lot in and seeing what happens…


#3

It seems importedmodel has no texcoord0 attribute. Well, I need to apply texture to my model first and then export to fbx


#4

You can switch between smooth and flat shading on an object in Blender by toggling this:

I created two UV Spheres, and set one to Smooth and one to Flat and I get this when importing those FBX files into PlayCanvas:

I had to create a new material and assign it to both spheres. I’m not sure why Blender generates FBX files with no materials, but anyway, that’s a mystery for another day. :smile:


#5

so, result is I should export models only with materials, right? Is just geometry not enough?


#6

Yeah, I would recommend ensuring all your objects in Blender have materials assigned. Alternatively, just remember to assign your own materials in PlayCanvas.


#7

I’m having the same issue with Maya and am probably missing a simple setting as well. Smooth mesh is checked on in my FBX export. I did not change any other default settings. Thank you.


#8

You shouldn’t have to smooth the mesh on export. Just ensure that you’ve correctly set up your normals in your Maya scene. I believe there’s an option to actually view the normal vectors. Check they look sensible (i.e. smoothed).