[SOLVED] FBX files no longer automatically converted to models?

Hi, I have imported 2 FBX files. Till recently, after uploading was completed, I got both a “Model” and a “Model (source)” entry. Today, I only get a “(source)” which I can’t add inside my project.

The source must be uploaded correctly because if I click on it, it reports the texture and the material names correctly on the right pane. It even allows me to view/download the textures but that’s as far as it gets.

Can you please tell me if something is going wrong?

If the project is public, what’s the link? If it’s not, can you add me? Username: will.

I created another project in case the greek characters were causing problems, but still no luck!
and the original

By luck, I right-clicked on the (source) files and selected “re-import”, this action created the normal “Model” files, textures and animations.

Is this now the way to create models? Upload them, then “re-import” them manually?

No this is not necessary this is just an option if you want to reimport a source file. This issue that you’re having might be related to having greek characters in the model. We’ll look into it.

There are no greek characters in the project, the materials or the model name…

What about the model itself - inside the FBX?

I tried another one downloaded from the internet. Neither of them seemingly contain any non-ASCII characters (inside or outside the FBX :smile:). I can’t upload it here but I can email it to you if you like.

Are you saying that the new model you downloaded from the Internet also doesn’t work? If so can you send it or just give a public project link so we can download it from there?

I just emailed you the model at your google account, but I believe the problem is not model-specific…

So I tried uploading that model and it seems to work fine for me:

Maybe there is a problem with your browser - can you check if there are any console errors in the browser when you are using the Editor? Also what OS / browser are you using?

Also check if you have disabled Auto-Run under Settings/Asset Tasks.

No, it’s not disabled. I just reuploaded Superman and had to “re-import” for it to work. Since the model gets uploaded, isn’t it a server issue rather than a browser issue? I didn’t manage to get any console errors. Firefox 42, Windows 7. Everything working normally up to last week…

1 Like

I can’t reproduce that on Firefox 42, Windows 10. You’re right to think that it might be a server issue and it might be however it is working fine for us and I haven’t heard about this issue from anyone else, that’s why I suspect it might be something about your account or your machine.

In order to get updates about assets as they are processed your browser is responsible for connecting to the relevant server to get updates so maybe something is wrong there. Can you confirm that this also fails in Chrome?

The steps I’m following are:

  • Create a new project
  • Upload
  • I see the progress bar on the asset complete
  • After a while I see target assets popping up in the asset panel.

If you fail to see the last step, then can you also try refreshing the browser AFTER step 3 without reimporting? Let me know if you don’t see target assets again.

Sorry for the inconvenience trying to get to the bottom of this :smiley:

Just tried on Chrome 47. Same thing. No console errors. Must be something with my account then.

How long it approximately takes from dropping file, till you get an error?

Could you try please again? And could you let me know how long upload usually takes?

I just tried, the Superman.FBX (2MB) was added as a Model Source as soon as uploading finished. An orange progress bar appeared below the Source icon for 1-2 seconds, then it disappeared but nothing else happened. I had to re-import it to get the json model.

Thanks for that info, so uploading is fine, it is triggering pipeline from editor fails.
Could you open Dev Console, and do it again, to see if there is any errors?

No errors, here is what Firebug tells me:

GET https://msg.playcanvas.com/messages/info

200 OK
messenger.js (line 3)
GET https://playcanvas.com/api/projects/368985/reposi...es?access_token=pa29h5h11okgox2cpjdej69tpefcelhe

200 OK
editor.js (line 325)
messenger connected
messenger.js (line 105)
GET https://playcanvas.com/api/projects/368985/assets...er&access_token=pa29h5h11okgox2cpjdej69tpefcelhe

200 OK
editor.js (line 325)
GET https://playcanvas.com/api/users/57285?access_token=pa29h5h11okgox2cpjdej69tpefcelhe

200 OK
editor.js (line 325)
unknown component “pack”, in entity 7b4c3626-b091-4153-a1a7-383582cf05f2
editor.js (line 47116)
GET https://playcanvas.com/api/files/assets/3052319/1…_blender.json?t=e323daa75287200cc9aa0af048c25aa6

304 Not Modified
playcan…able.js (line 13791)
POST https://playcanvas.com/editor/project/368985/asse...ad?access_token=pa29h5h11okgox2cpjdej69tpefcelhe

201 Created
editor.js (line 325)
Profile (204.024ms, 2094 calls)