[SOLVED] Failures in the final rendering

My project has started to look like this

but 2 days ago when he was finishing it, it looked correctly like this

notice that all the vegetation has a marked white border, the horizon line too, has something happened with the alpha channel?
I don’t see the shadows either

This is another one of my projects, it has the same problem

This is how a version I have online looks correctly

and this is what it looks like now if I open the project in the editor

I need urgent help to solve this, they are projects in which I am working and I must deliver progress

Are you able to create a small repro project with one of those trees, that reproduces the issue?
Just looking at the screenshots, nothing comes to my mind.

Can you try your project with an older engine to see when this got broken?

The fault is in all versions of the engine, and seems to affect everything that has a cutting mask

You can also see the failure in this UI element that uses alpha channel, like all trees

here in the oldest version that I can launch

I’ll see if I can prepare a public project of this. But, did this happen to anyone else? This is something quite serious

I have simplified my project to the maximum, until you leave only a few trees, but I have kept all the configuration of lights, cameras and engine setup, the result is still the same, my trees with a white border, and the transparencies also as tinted with white

I have taken the same tree to a new project, and the problem does not appear, obviously there is something that has broken in the configuration that I have in my other projects

Here the access to the project

Overview | Dashboard | Espinal Blender 06 Falla | PlayCanvas | 3D HTML5 & WebGL Game Engine

Compare rendering settings, in Settings->Editor, maybe there is a difference there.

At least it seems like this might not be engine change related, if this works if you copy the data to another project.

Keen to DM me a link to this a published build of this simple broken project? Perhaps public both broken and correct, so that I can compare.

Hey I’ve just noticed the project, when I posted my previous message.

Have you tried increasing the Alpha Test values on your material? Those are currently around 0, try to move them to perhaps 0.8?

Also, looking at your texture, it has lots of those yellow / bright pixels around the actual texture colors, and that would be the reason. It seems you used some tool to spread the colors outside, which is a perfect solution here, but why are those pixels not green?

I understand what you’re telling me, but this works fine in a new project, and it always works fine in many projects I’ve done, they’ve changed something, and something’s broken, because now all my projects look bad, and I can’t go one for one fixing this, there are many projects and a lot of vegetation with types of trees, it is not just one tree. Can you please fix this for me.

Try to put this tree in a new playcvanvas project, and you will see that it works fine

@mvaligursky Could this be related to the launch options issue that @yaustar submitted a PR for today?

Yes, it looks like we have a fix, we’ll test it during the week and release it when confirmed.

Fixed is confirmed, we’ll do some more testing and release it today / tomorrow.

OK, I’ll be waiting, thanks for the support

1 Like

The fix is now deployed. Let us know if there are any more problems related to this.

1 Like

All my projects are working fine now, thanks for fixing this quickly.