[SOLVED] Failing to load ammo.wasm.js

I’m getting an error when I launch PlayCanvas in the Oculus browser that it cant find ammo.wasm.js

This is just after I hit the import Ammo button when I added a RigidBody component to one of my entities.

Here is my game: https://playcanvas.com/editor/scene/889297

1 Like

Hey @slimbuck - can you verify loading Ammo works in the Oculus browser on your Quest?

1 Like

Hey Will, I don’t know if you ever got around to this. But I am seeing the same thing happen when I try and load the application up on Safari on my iPhone.

Hi @Tom_Scanlan,

Sorry it’s taken so long to look into this. I’d like to test both quest and safari.

The project link above doesn’t include ammo?


Hey, sorry. I had to take it out of that project in order to get it to stop erroring out. But this is the link I tested on my phone.


Hi @Tom_Scanlan,

Finally got a chance to try this on iphone. I reproduced the issue you found. What happened with me is this: attempting to load https://launch.playcanvas.com/896727 caused the playcanvas login screen to pop up. After entering my details and logging in I was met with the error loading ammo.

However the browser had taken me to https://playcanvas.com/editor/scene/896727/launch instead of launch.playcanvas.com/896727. The former URL doesn’t work at all, not even on desktop chrome, but after re-entering the correct launch URL it worked fine.

Please could you check whether the same is happening to you? Make sure you’re logged in to playcanvas and then navigate to the launch URL. I guess the playcanvas.com login screen has a legacy URL that should be updated.

@vaios do you have any idea what may be happening here?


1 Like

Ugh! That was the issue. Thank you so much for figuring this out.

No probs, we’ll try fixing the issue on our end.


Just noticed this still seems to be an issue @slimbuck. Also there seems to be a situation on mobile where the Login via Google screen opens the auth popup, but the redirect just lands you back on the login screen again. will try and get a more thorough repro

This sounds like a separate issue. Do you have more than one Google Account signed in the browser?

Can you also try clearing cookies and cache or signing out from google.com and then try logging into PlayCanvas via Google Auth?

1 Like