[SOLVED] Error when creating a template

I am trying to create a template from this entity in my scene hierarchy:


For some reason it gives me this error and the template is not created:

Weirdly enough it just doesn’t work on this entity. With any other entity in my scene I can create a template.

calling @yak32

I also tried to replace the parent entity with a new one, but it still doesn’t work

Hey @Timo are you able to share the project, or copy the entity out into a new project if it’s sensitive?

Sure, here you go:


Thanks @Timo. Are you able to create the template in that new project? If I fork, it works for me, although it is missing all the sub assets, which might be causing the issue.

No I have the same issue. If I copy another entity from my scene (which is also missing files then) it does work. I am clueless here hahaha

I added the other entity which does work also to the blank project. Maybe you’ll see the difference.

I am getting the feeling it has to do with the fact that this entity was another template. I unlinked it in the hierarchy, modified it, renamed it and tried to create a new template from it. Somehow under the hood it seems to be connected to something.

I found the issue.

There is a new child entity within this entity which is really big. I think Playcanvas rejects me from creating a template that’s this big. It worked for you @Mark_Lundin because the files where missing.

Is there a limit to how big templates can be?

Pinging @yak32, he might know

the fix is implemented, we are going to deployed it soon today

the fix is deployed to production, please check on your side

I tried it and it works, thank you!