[SOLVED] Error loading scripts. Open the browser console for details

Help!!! I’ve suddenly started getting the following error for my project.
I get the error in Chrome (in Incognito and normal modes) and Edge.


VM1162 otBannerSdk.js:7
Uncaught TypeError: Cannot read properties of undefined (reading 'TenantFeatures')
    at VM1162 otBannerSdk.js:7:380552
    at VM1162 otBannerSdk.js:7:381514
    at VM1162 otBannerSdk.js:7:385524

Hi @CarlBateman,

Are you still getting that error? Running your project seems to work for me, no error in the console.

It runs with no errors when starting by clicking [Play] on the project page, but I get the error when I launch from the editor.
Reloading the page clears the error sometimes.
I’ve cleared cookies but still get the errors.

More testing, moar browsers:
No errors in Opera.
Errors in FireFox.

The errors come from onetrust-banner-sdk.
Does PlayCanvas use OneTrust?

It may be for analytics or something. There is an ongoing 504 server issue currently being investigated by the PlayCanvas team.

Do wait for that to be resolved in case it’s related to your issue.

This is now resolved.

1 Like

I closed the project, cleared the cache and cookies the issue persists.
Is there any other action I need to take?

Oh actually, I thought this was related to the outage that occurred this morning, but it might not be.

cc @slimbuck

I’m not sure why, but the gif.worker.js script interferes with our consent system resulting in the error messages you’re seeing. If I exclude that script from the build then the project runs fine.

That seems to have done the trick. Thanks!