[SOLVED] Error in Start Published Build

Hello playcanvas team, I have a problem that came out of nowhere.
When I start my game from the editor everything works fine, but when I publish it and start the screen it goes blank, it only loads the html resources and the following error appears in the command console:

I hope you can help me, because I really don’t know what it could be, everything worked fine, and I was just programming a few lines of code and adding a zombie model.

this is my scene: https://playcanvas.com/editor/scene/1224175

The engine that just got released might be causing it … we’ll investigate.

1 Like

I think the new v1.48.0 hasn’t been promoted to editor based projects yet, it’s still running v1.47.2 when you launch.

1 Like

I was just worried that published version is 1.48.0 … but it seems maybe that’s not the case either.


it seems to me published builds use 1.48.0 … something we’ll fix tomorrow.


It seems I am getting similar errors with v1.48.0, scripts complaining on their update method something is not initialized.

Was there any change in the behavior of the script component system like order of execution etc?

1 Like

This has now been fixed. Please try publishing again and thank you for letting us know about the issue!

1 Like
1 Like

Yes, I’ve just found it, we were using this code in a custom system of ours:


Which now should be replaced with this:

app.systems.fire('initialize', entity);
app.systems.fire('postInitialize', entity);

Thanks, everything works fine! :smiley:

1 Like

and we have a fix to the original reported problem as well … so when the engine is released to the Editor, the problem won’t happen.