[SOLVED] Editor not Loading in Safari 14.0.1

Hey all, right now on safari whenever I load the editor I am getting a blank screen on all of my projects (the PlayCanvas grey color). I am getting this error in the console:

SyntaxError: Unexpected token ';'. Expected an opening '(' before a method's parameter list.

It says it is coming from editor.js line 804.This is line 804 of that script:

static history;

Let me know if there is any more details I can give on this. Very odd. It doesn’t give me this error on Chrome.

Which version of Safari are you on? I can’t see it myself on Safari 15.

Does this happen if you use a private tab/window?

I’m on 14.0.1 Let me update real quick

Also, if I use a private tab the issue persists.

Trying to find someone with Safari 14 :thinking:

We have isolated what the issue is and will be fixing it as soon as possible

1 Like

Okay thanks for getting back to me. I just updated my safari to 14.1.2 and that fixed it as well.

We deployed the fix. The Editor should now support Safari going back many versions. :grinning_face_with_smiling_eyes: