[SOLVED] Console error from latest playcanvas


#1

I’m getting error from latest playcanvas version.
It happens after entity destroy.

Is there anyway to solve this problem?


#2

I’m unable to continue my project because of this bug.

Project ID : 656900

Is there anything I could do to fix it? I didn’t make any changes in recent two days but the problem occurred yesterday, I think after recent update.


#3

Hi @commention,

Thanks for reporting this issue, we are having a look at this.


#4

You can continue your project by checking out the documentation on this page:

https://developer.playcanvas.com/en/user-manual/scripting/custom_engine/

So, for you, you’d add:

?use_local_engine=https://code.playcanvas.com/playcanvas-1.9.0.js

…to your launch URL. Or change the ? to an & if you already have URL query parameters in your launch URL.

Are you able to provide an example that reproduces this problem so we can debug?

CC @dave


#5

Hello,

Before start to use local engine option on my project, I’ve just tested it again and looks like it works properly.
But before that I’ve tried to change light’s “Update mode” to once. And back realtime again.

It seems to me that the issue was on light engine or something. And after changing this params, it start to work properly. Now I’m unable to reproduce issue. It just works.

Please let me know if there is anything I could provide to investigate issue.

Best regards


#6

Hmm. Let’s mark this as resolved for now. But if I are affected by a problem like this again, feel free to post again and do try to include clear, detailed steps to reproduce, ideally with a test project URL. Thanks!