[SOLVED] Change in rendering, models washed out

Hi everyone, long time not posted here :slight_smile:

I’m working again on my configurator, and I’m having a bug I don’t understand…
I haven’t toughed the lightning, materials and rendering settings (at least, I think…?) for a while, and I’m having a big rendering difference between my last build in July 13, and today.

Here are some screenshots, before and after :

Also inside the editor it still looks OK :

No bugs in the console. (no new bug at least :slight_smile: )
I tried changing the editor versions between 1.55.4 and 1.56.0 but no changes.
Playing around with the rendering setting didn’t solve anything.

The materials still look ok in the editor :

Any idea where I should look?
I can’t share a link unfortunately as the configurator works inside a private website, so a direct link to a build will just show an empty space. It needs some instruction and data from the website to know which parts and textures to use.

Thanks in advance for the help ! :slight_smile:

PS : Showing text still look kind of fine, I don’t understand whats happening…

Hello @TonyLGC!

There have been some changes in the specular settings, can you please check if you’ve set refraction index (under the Environment tab in the material) to something other than 0.667? If so, perhaps that setting will solve this issue.

If that doesn’t work, would it be possible to share the project with us to take a look? We have made some substantial changes to the specular shader code recently so this probably relates to those changes :slight_smile:


I’m not sure if this is the same issue, but I experienced something similar with engine 1.55.0 and later. I made a topic about it a few weeks ago.

My solution was to reduce all the non-glossy materials’ reflectivity to 0. Materials have a default reflectivity of 1, this is a separate setting to the specular glossiness.
Screenshot from 2022-08-08 20-19-50

Hi @Gustav_Sterbrant :slight_smile: All the used materials did keep the standard 0.667

I made a kind of stand-alone fork stripped of all the configurator stuff, but which keeps the rendering problem :
A build : Configurator demo - PLAYCANVAS
The project : https://playcanvas.com/project/981378/overview/configurator-demo

Thanks again for the help :slight_smile:

Thanks for the response ! Unfortunately this only made things appear darker but that’s all

The issue is that skybox layer was not enabled on the camera to be rendered:

Ticking that gives you the following result with the skybox reflections:

1 Like

Oooooh, why are the most annoying bugs always the ones with the most simple solutions haha.
Thank you very much !
I guess I have missclicked that at a moment?

It was due to a change in the engine. We have made some major changes in the shaders in the last release or two that changed the behaviour of when/how the skybox is rendered.

@Gustav_Sterbrant should be able to explain more but I would assume its to help reduce complexity of shaders or making the behaviour more ‘correct’. (If you aren’t rendering the skybox layer, why should it appear in reflections?)

1 Like

Ironically I’ve got a regression thats the opposite problem. The skybox is overwriting the envAtlas reflections, working on understanding it now.

Can you post a separate topic with a repro please? Perhaps one of our graphics team can help

will do as soon as I have more information

1 Like