[SOLVED] Car Third Person Camera shuttering


As you can see in image i manage to set third person camera to car which is way very well realistic.

But when car moves, cars seems shuttering…

Here is project link:

Try to make it follow “Chassis” instead of “Car Physics”

1 Like

I did this and it work well…
@_thorce Thanks for help it help to reduce shuttering but still getting ~40 Frams… :smiley:

But i want more smoother gameplay so I Checked Transparent Canvas

So its very smooth and playable with ~60 Frames… :wink:


1 Like

Odd that this gives higher performance :thinking:

1 Like

Maybe there is something hidden potential behind Transparent Canvas… which i seriously dont know code wise what it does…

Even I observed the same thing with FPS Controller… when i dont enable Transparent Canvas the mouse movement is little bit slow also FPS drops…

You guys may need to do some research on it… :thinking: Something must be there which smooth out performance like never before… :slightly_smiling_face:

I just tried to fork your project and also checked the first person movement one from the tutorials. Both projects give me stable 60 FPS with and without transparent canvas setting. I also throtteled my CPU, and I get about 55 FPS with and without the transparent setting.
This setting should not affect the FPS. There must be something else, related to your browser.

@LeXXik I am using macmini


:arrow_forward: See Frames drop here here without Transparent Canvas (Even when i move car it started shuttering)

:arrow_forward: With Transparent Canvas

I tried same with Incognito mode where i got same result as i mentioned…

@LeXXik Did you try to reload the game completely? when check / unchecked the Transparent Canvas

Not sure… :thinking:

@Ketan_ATA yes, I just tried it again. Cleared the cache to make sure.
Also, my laptop is from the same age as yours, but it is a PC using Windows/Chrome. Are you running in Safari? Can you test with another browser?

@LeXXik I really feel like

My Whole Life Is A Big Lie

My Bad :face_with_raised_eyebrow:

After checking Safari browser… I came to know that there is issue with Chrome.
Something is seriously wrong with my Chrome (Chrome Incognito mode also gives same issue) where game work smoother when Transparent Canvas is enabled.

@LeXXik Thanks a lot…