[SOLVED] Cannot read properties of null (reading 'start')

So when I load this scene ‘Game’ it gives me this error at the loading screen before the scene even starts.

I don’t know what it is or how to fix it at all.

but I would appreciate some help, or at least an explanation.

Thank you.

@DinoCalebProductions Would you be able to share a link to your project so people can have a look? Also one good hint to try to locate this is to click on the red text on the bottom. It should take you to the debug script to see what it is getting hung up on. Also, it looks like you are using chrome. If you hit F12 key you can pull up the debugger output. Refresh the screen and this may also point you to the issue.

When I click on the red text it takes me here.

I’m only at the beginning.

About halfway through I see this.

this is at the very end.

I don’t know what this is but it’s not mine.

And I’m not trying to be sarcastic I’m just showing a fraction of what I see. It goes a long way down.

But thank you.

Tirk182 mentioned if you can share a link to your project? Can’t really say what the issue is without seeing or looking at a reproducible unfortunately.

Judging from your other thread, it’s this project https://playcanvas.com/project/906544/overview/metal-game

Tracked down the issue, the file Metal-Impact-Hit-E2-www.fesliyanstudios.com_1.mp3 is corrupted and is being used here:


Changing the sound used or reuploading that file should fix it.

1 Like

I just saw your post today and you were right, that was the problem.

Thank you very much. I never would have guessed that the sound was corrupted.

Sorry for the late response. It was bed time for me.

But thank you very much

I will mark this as SOLVED.

1 Like