[SOLVED] Cannot play published game

I have published my project. For some reason it will let me view the main menu, but when I press space to advance to Level 1, it tells me I need to login. When I try I get an error 403. This is the link to my project.


It is also important to note I have deleted the published version since it did not work.


This is not the correct way the change a scene.

Can you try to replace window.open() with the method below?

this.app.scenes.changeScene('Some Scene Name');

@Albertos Ok I will try that.

@Albertos It worked! Thank you very much for helping me out!

Great! :slightly_smiling_face:

You should apply this wherever you want to change the scene.

Will do! For some reason my Game Design course said that using the change window method was correct. The changing scenes the way you said works so much more efficiently.

1 Like

It is a pity that the course provides incorrect information. If you have the opportunity, you could ask them to correct this. They can also contact the PlayCanvas team for support.

1 Like

@Michael_McPherson From this post we have seen the same issue. I agree with @Albertos