[SOLVED] Cannot choose color in particle system inspector


#1

Today I tried to add a particle system in my pet project.

However, I was not able to change color in inspector. Moreover, when I edit scale curves for particle system, color goes transparent by itself.

I have a barrage of error messages in console:

picker:gradient:set (editor.method error)
editor.js:17882 TypeError: Cannot read property 'createLinearGradient' of null
    at ColorPicker._generateGradient (editor.js:85437)
    at ColorPicker.set (editor.js:85541)
    at ColorPicker.set (editor.js:85584)
    at selectAnchor (editor.js:85914)
    at setValue (editor.js:86140)
    at editor.js:86287
    at Editor.call (editor.js:17879)
    at CurveField.<anonymous> (editor.js:54912)
    at CurveField.Events.emit (events.js:57)
    at CurveField._setValue (editor.js:7935)

I would go and make a pull request or issue on github, but I understood that editor is not open sourced

Solution: Turned off Webgl Insight browser plugin.


#2

Hi @nikita_osyak, indeed that error comes from the editor side.

I wasn’t able to reproduce following these steps:

  1. Create a blank PlayCanvas project
  2. Add a Particles component to an entity.
  3. Change the color or any other curve.

That seems to work.

Could you share a link to a public project where you get that behavior?


#3

Sure, @Leonidas, here is the link to my project. It has single scene, and in it the issue seem to reproduce 100% https://playcanvas.com/project/618847/overview/temp


#4

Thanks @nikita_osyak, on which entity did you try to add particles and you get that error message? Any?

Tried adding to the last one harry and it seems to be working (tested on Firefox and Chrome):


#5

Interesting. Does not seem to be working for me, have the same problem. Should be something local then


#6

Just tried to upgrade my chrome, not helping.

I have to point out that I use mac. Mb that have something to do with it?


#7

It shouldn’t, it might be a combination of your GPU/osx drivers though the error message you posted above is more of a CPU/logic error instead of a graphical one.

Can you try and fork/play with the default particles tutorial projects and see if you get the same error?

https://developer.playcanvas.com/en/tutorials/?tags=particles


#8

Figured it out. Looks like some kind of problem with local caches.

It works fine on firefox and even in new incognito window in chrome. I cleand my cache but it still not working in the old window… So it’s totally something with my local software.


#9

Do you have any browser extensions installed?


#10

Yes, lots.

AdBLock, friGate Light, MetaMask, PixiJS devtools, React Developer Tools, Spector.js, Vue.js devtools, WebGL insight


#11

If you disabled all the extensions, does this issue still come up?


#12

Oh, wow.

Using your advice I was able to specifically determine which extension cause the problem!

It was WebGL Insight. What a weird collision. Turning it off and reloading the page completely fixes the problem.

Thanks, @yaustar!

Now I have pretty projectiles :slight_smile:

Oct-28-2019%2000-51-16