[SOLVED] Cannot change Loading screen

Hi ,
Its been a while since I have been trying to replace the current loading screen with my own version. I know that it needs an ORG account but tell me how this works - How can I have an organisation plan since if I have the plan I cannot login through that account. I am the admin of a project that is owned by an organisation with an organisation paid plan. But I still cannot change the loading screen. Btw , it gives me the 2 options of changing the loading screen ( the default and use existing ones) so that means I should be able to change the screen but when I drag the script into the option, it appears and suddenly resets to the same 2 options as before. Is it a bug ? Tell me what am I missing here.


Just tried it myself without too much trouble.

I click on ‘CREATE DEFAULT’ and name the script. That script should be selected by default for the loading screen script.

Can you create a screen capture/gif of the issue?


I’ve fixed an (internal) issue with your project which was causing this to fail. You should be able to add the loading script with no problems now.

Sorry for the inconvenience.


I am having the same exact issue as reaper235 is having. I have and ORG account but, everytime I drag the default script into the option it reverts back to original options. Do all ORG accounts have the same internal issue?


I have the same issue. How can I fix it? Project is https://playcanvas.com/project/495159

Your project should be fixed now. We’re rolling out a permanent solution to this bug soon.

Sorry for the inconvenience.


I have the same issue these days. Some of my projects transfer ownership to organization.
Everything is OK expect selecting the exist loading script. When I open the console, it says:

playcanvas Loading screen only allowed for Organization accounts

This is very confusing. As the project has transferred to the organization. But I find a workaround, just fork the project and set the owner to organization and delete the original project, then you can select existing loading script successfully…

We deployed a fix for this yesterday. Let us know if you’re still having problems.

Hi looks like I have the same problem, cannot change the loading screen (project is about a month old, and we do have an ORG account), trying to create a new or select an existing loading screen does nothing, trying to drag a script on the Loading Screen section in the editor UI you can see that some text is displayed for one frame and then the UI reverts back.

On the JS console there’s an error displayed:

editor.js:14888 Error: invalid:type(2)
at Connection.handleMessage (editor.js:12968)
at socket.onmessage (editor.js:12921)
at WebSocket.connection.socket.onmessage (editor.js:14643)
(anonymous) @ editor.js:14888
emitOne @ editor.js:10484
emit @ editor.js:10562
Doc._clearInflightOp @ editor.js:14283
Doc._rollback @ editor.js:14249
Doc._handleOp @ editor.js:13662
Connection.handleMessage @ editor.js:13039
socket.onmessage @ editor.js:12921
connection.socket.onmessage @ editor.js:14643

Confirmed, we are getting the same error as @Andre_Weissflog:

Can you guys share the IDs of your projects or links to your projects?

Never mind guys that was a regression introduced recently to the Editor. Should be fixed now if you refresh your Editor. Thanks for reporting this!

1 Like