[SOLVED] Blank Screen when Clicking on Launch Button

I am facing this issue - when I click on the Launch Button, it shows me a blank screen and doesn’t show me the contents of the project I made. Previously it was working fine but suddenly this issue is there. I have tried it on both Chrome and Firefox and the issue is there in both web browsers.

Hi @Kavi_Kumar and welcome,

Do you have a camera entity in your scene hierarchy? That is responsible for rendering your scene when hitting launch.

Yes I have a camera entity in my scene hierarchy

Can you share the project please?

Okay. Here’s the link to Project Files -

Hi @Kavi_Kumar! If you share a link to your project I can take a look if you want.

That’s the build files which I can’t import into a new project. Do you have link to the PlayCanvas project that we can try ourselves?

I found your public profile and project here: PlayCanvas 3D HTML5 Game Engine

The scene to reproduce on is Forest Scene

Found the issue:

You have a second camera as part of the model import of the Elephant.

Delete this camera and it will render the scene from the camera that you’ve placed yourself.

When exporting models from your 3D tool, please don’t include any other objects that you don’t want (eg cameras, lights, etc).

Fixed fork version: https://playcanvas.com/editor/scene/1243371

1 Like

Thanks for pointing out the issue. When I delete that camera inside the 3D Model the main camera worked fine and there’s no issue now!
Thanks for your time. Really appreciate your help!