[SOLVED] Attributes not visible in editor

Hello, i have some attributes at the start of my script, but the editor don’t show them when i click on the script, why?

Hi @ayrin,

Did your press the script parse button after saving your updated script?

Usually that’s the issue with missing attributes, apart from wrong/missing definitions.

And to be clear, the script has to parse successfully for the attributes to show up. If it fails parsing I don’t think they’ll appear.

1 Like

js%20script js%20show
Script and attributes screenshot, parse?? where? lol

Ah, so you are using Legacy scripting. I can’t remember right now the full definition or if something is wrong (nor I can test, sorry no Legacy Script available).

Maybe @will or @vaios can help with this or instruct you to update at some point :slight_smile:

1 Like

Find your script in the Assets folder and click on it. That will bring up a panel that contains the parsing option.

… or not … there may be something about the Legacy Scripting that Leonidas mentioned that I’m not aware of.

If you look at the entity that the script is attached too, do you have that little “parsing” gadget? You can see it called out on the Zoom script in this image.

Yes, as @wturber suggests you can find that button on your component for each script attached (and not when selecting a script asset on Legacy scripts):

image

Thanks guys, yes you are right, i was searching in the wrong place, thanks to all

1 Like