[SOLVED] Any ideas about a CORS error for s3-eu-west-1.amazonaws.com/apps.playcanvas.com from playcanv.as?

Hi all,

I hope it’s ok if I post a help request, here.

I’m learning the project and PlayCanvas so I may not be able to answer all questions. If anyone has any ideas that could help me resolve the issue then I would appreciate it!

The issue is that the project isn’t displaying at the published primary build link. I get a black screen, aside from the PlayCanvas footer. The Chrome console shows a CORS error for basis.wasm.js

For now I’m not sharing the link and I obfuscated a unique identifier in the screenshot.

The denied resource URL seems to be a regular PlayCanvas domain, no? Why would it be denied?

I tried a couple builds, a new one and the one that had been set as primary build for a while, which is from 4 months ago.

Hi @3dTim and welcome,

That’s quite strange, not sure why it would happen. A few things to try:

  • Opening the same build from another browser, in case some browser extension is causing this

  • Create a blank project, add basis and try publishing a build. Check if you get the same error.

1 Like

Hmm, we’ve had some reports of this from users and are looking into this. So far, it only affects our hosting on playcanv.as

1 Like

Is this an older published build? If so, can you make a new build and see if the issue still happens please?

Hi yaustar,

Thank you for your responses.

This issue occurs the same way for a 4 month old build and for new builds that I created yesterday and today.

Are you able to DM us the build from 4 months ago and the new build for us to look at please?

also, could you disable cache in Dev Tools and test the project?

1 Like

I disabled cache in Dev Tools, and the CORS error issue is resolved.

Was something changed on the server side?


We moved to a caching mechanism that allowed us to lower latency and higher speeds. It seems to have caused an issue with WASM modules in particular that we are investigating


nothing yet changed, we are testing it. Could you also check one more thing for us - do you have “preload” field checked for basis.wasm, basis.wasm.js in your assets?

Hi yak32,

Yes, ‘preload’ is selected for basis.js, basis.wasm.js, and basis.wasm.wasm

ok, I think we have a fix for you, should be released soon

1 Like

Hmm, it should be not ticked as preload (we should prevent it from being ticked as preload). Can you untick and create a new build please?

No problem. I deselected “preload” for basis.wasm.js, and made a new build. DMing the link.

@yak32 has a proper fix incoming, we will update the thread when it is released :slight_smile:

1 Like

The fix is deployed, please re-build your projects. (it’s needed if basis is preloaded for some reason). For anybody interested - AWS S3 bug report about similar issue and similar issue explained

Release notes: https://github.com/playcanvas/editor/releases/tag/v1.21.18

You will need to re-publish the project as it’s a change to the HTML and JS boilerplate

Thanks, all. I made a new build, with “preload” deselected for basis.wasm.js, and there is no CORS error.

Can you say what the best practice should be, regarding the “preload” setting and this issue? Am I correct to understand that .wasm.js files should not be set as preload? Or is it any basis file that should not be set as preload? Or can developers go either way? @yaustar @yak32


The Basis WASM library files should not be preloaded :slight_smile:

Thanks again for reporting and testing

1 Like