[SOLVED] Animations not working, however preview IS working

I’m trying to get a pretty basic animation working.

I’m using assets from Mixamo.

I’ve got a pretty basic set up and as far as I can tell everything is correct. I’m pretty sure the models and animations themselves are fine because when I set the preview model of the animation to the same model I am able to see the preview animate correctly.

However, when playing the scene nothing happens and the model is stuck in its default T-pose. Activate is checked and I am using the Anim component.

I’m hoping I’m just missing something obvious!

Link: PlayCanvas | HTML5 Game Engine

Your character doesn’t have an armature, it is just an entity with a render and anim component. You should instead use one of the templates that was auto created when you uploaded the assets. In the Mixamo folder, try dragging and dropping the Idle or Walking template into the scene and see if that works.

1 Like

Hi @mr_mr,

Not sure why importing the model with “import hierarchy” doesn’t run the animation, anyway I was able to run a Mixamo animation on your character, here’s how:

  1. Uploaded your character to Mixamo
  2. It automatically rigs it and I downloaded an animation
  3. Disabled “import hierarchy” from the settings

The animation from Mixamo works fine now,

Thank you both, I was able to resolve this with the help of your replies.

As @Devortel suggested, the render component was not rigged. You can tell if it’s rigged because the bones will be visible when it is in the editor. When I added the template component instead and then selected the hips as the root bone it worked as expected.