[SOLVED] 8th Wall AR crashes upon loading on iPhone 12 Pro


I’ve been working with 8th wall AR on a project and we’ve been testing on a multitude of devices as of late, and we discovered that on iPhone 12 Pro, any build with 8th wall crashes upon loading.

The iPhone we tested with is on iOS 14.4, but this behavior was also observed with 14.3

We’ve tested this with the 8th wall world tracking starter project in a build (where all we did was change the app key so AR would allow our devices to use the tracking), forked from here https://playcanvas.com/project/631719/overview/ar-world-tracking-starter-kit

We received the following errors when debugged via mac safari debugger:

Here is a photo of the browser after the crash:

Any insight here? We’ve concluded that it’s not something relating to our specific project (such as memory leaks, vram usage, custom device camera setting code, project settings, etc)



I’ve forked the starter project and tried on an iPhone XR, 14.4 and Android Google Pixel 2 XL and it works fine on both devices.

It might be worth asking on their Slack to see if they know what the issue could be?

1 Like

One thing we found interesting as well that I forgot to mention is that we tested the 8th wall AFrame example on 8th wall’s site with the iPhone 12 Pro, and it ran fine, only when it was a playcanvas integration did it crash.

All other iphones seem to have no issue running it.

I personally don’t have access to that phone model. I can check with the team and try an emulator for the phone to see if we have the device and repro.

1 Like

Make sure “WebGL 2.0” is disabled under Safari settings:

Settings -> Safari -> Advanced -> Experimental Features -> WebGL 2.0

This is an experimental feature and disabled by default on devices. It seems Apple has been working on adding support for WebGL 2 since 2014 but it’s not quite there yet:


Screen Shot 2021-01-21 at 2.39.52 PM

I just tested the 8th Wall World Tracking Starter Kit projects as well, nothing modified other than adding my unique appKey, and it worked just fine on my iPhone 12 Pro Max running iOS 14.4

Then, I enabled WebGL 2.0 under Safari’s experimental settings and I was able to repro this exact crash.


Can confirm that this was the issue, our iPhone 12 pro user had WebGL 2.0 in experimental settings ticked on, after turning it off, our builds runs.

Thanks @atomarch @yaustar


Great, I’m glad this resolved your issue. Thanks for the update.