Skybox shadow acne

I’m using the default prefiltered helipad cubemap, and for some reason I’m getting these ugly shadow artifacts on my imported GLBs.

This is without any dynamic lighting in the scene. Is there a way to blur the shadows from the cubemap the same way you can with point and directional lights?


Edit: This seems to happen even with a regular primitive sphere in a new default Model Viewer project

This problem no longer occurs when I replace the playcanvas-stable.min.js with an old version I have.
This appears to be some kind of regression

That’s interesting … what OS and browser, including version, do you get this one? Are you able to share a small repro project?

64-bit Windows 10, happens on both Chrome and Firefox from what I tried.

This happens just on a new project, so the latest version of PlayCanvas.

All I did was make a new model viewer project and add a primitive sphere, basically anything spherical will have these shadow problems caused by the HDRI

I also opened the same project on my work computer and Android and they both worked
as normal, so there must be something different about my desktop that’s going under the radar.

I’ll update my Nvidia drivers when I get home and see if that fixes it

1 Like

Hi @Syntactic_Cherry,

I can try this on my windows machine too. Just wondering, do you see any errors on the dev console when you get the acne?


1 Like

Tried on my dell XPS 15 running windows 11 under chrome and firefox, no issues.

Tried on windows 11 chrome here, could not repro.

1 Like

Nah, no errors in the console. Updating the Nvidia drivers also didn’t work. I’m running a Geforce RTX 3070, Direct X 12. I can’t imagine any of those matter though

In any case, I appreciate the help. I gotta get this project done real fast though, so I’ll be back to figure this out later. I really prefer Playcanvas’ API over Babylon and ThreeJS, but I’m kind of on a tight schedule with this one so I’ll probably just use ThreeJS and re-open this later if it’s still happening on later versions.


Ok @Syntactic_Cherry thanks for letting us know, I’m sorry we couldn’t get the issue sorted.

We’d still love to get to the bottom of this, so if ever you get new info on what the possible cause might be please do let us know!

1 Like

Does the issue occur with 1.50.2 of the engine? You can test via the drop down in the settings of the Editor (current session only)

And opening the launch tab will add the version as URL param.

It’s also selectable when you publish:

Odd that it only affects your PC at the moment :frowning:


It looks like all 3 versions available there have this happen. The version that I have that does not have the graphics problem is v1.45.3, but I’ll upgrade and go through them to find out what the actual last working version is when I get the time. I’ll bump this thread when I find out.

Thanks for looking into it!

1 Like

My bad, I didn’t realize that the versions don’t take effect until you hit play.

You were right, the change introduced after version 1.50.2 is the cause: