Script attributes wont load in the Editor

//Object doesn’t support this action

script attributes wont load in the playcanvas editor after refreshing

anyone know how to fix this?


I forked your project and hit the refresh button on the script component of the Ball entity and it worked fine.

What browser are you using?

still doesn’t work. Internet Explorer

There seems to be a bug in IE at the moment surrounding script attribute parsing. I’ve logged an issue. Should be fixed shortly.

1 Like


This should now be fixed. Let us know if you still have an issue.

1 Like

Thank you so much for PlayCanvas guys! I’m a 20yr old that has been lost in the world not knowing what to do with my life but now that I found game dev through PlayCanvas I finally found purpose. I’m hooked! looking forward to making the world a better place through video games with the PlayCanvas Community.

I’d like to wish you good luck! We are here to help. :slight_smile:

thanks. it worked! :smile:

hello. can’t add materials

Can you see anything in the javascript console when you create a new material?

No I don’t see anything

We’ve logged this as a bug. I believe a ‘workaround’ is to collapse and reopen the Assets panel and then the ‘+’ menu works.

the JavaScript console reads:messager.js 0: Script Error
I cant see anything on the editor nor when I launch a game.
please help

I have the same problem. When launching locally from the Editor, I get an error message at the bottom along the lines of:

“Script: http://localhost:51000/camera_manager.js failed to load”

This occurs even when I make a fake script and attach it to an entity component. Any thoughts?

If you navigate to that url in browser, do you actually get a script then?
If no, then your local server is not serving scripts right.

Hi, The script attributes won’t load in but my script is fine. Here the link:
Can someone explane me this?

Hi @GameDev077 and welcome,

Your code seems fine, I think the issue is you haven’t saved the script file (its filename is in yellow color) when you updated the script attributes.

Try saving it (Ctrl + S) and then parsing it again (Parse button on Inspector panel).

1 Like