Scene loading not working in published build [SOLVED]

Hi, I am using a scene loader inspired by Playcanvas Tutorial “Changing Scenes”, which load scene hiearchy from starting scene to another scene I wrote as an attribute. Working perfectly fine in editor mode, but Playcanvas seems to refuse / deny some files and causes me a fatal crash while loading

Here is my console error log on Google Chome, same thing happening in Safari

Here is my Scene Loading script :

Very strange error, I never encountered this in the past. Thank you for your help,

Here is the callback from Amazon’s server (where Playcanvas Cloud build is stored) :

Can you post a link to a public project please?

At a stab in the dark, have you forked your project and not updated the scene ids? (they change when you fork unfortunately).

Thanks for the info, I will check when I am forking my projects. I believe it is due that I was not including the second scene in my build, i didn’t notice at first, but I forgot the check the second scene in the publish settings (noob error), I will confirm if it’s working and will put this thread to solve if it was the cause of this issue.

1 Like

Problem SOLVED, due to : Not including the second scene in the publish settings.