Problem with unfiltered texture

My project:

Notice the small distinct blue eyes: (click the pic to see the full pic)

In PlayCanvas the eyes blur.

I tried a lot of settings in the editor but I can’t figure out how to fix it. Note that I want it to look pixelated.

When you upload image, in order it to work well in WebGL, image gets resized to power of 2 resolution.
There are two things you can do:

  1. Disable Auto Run in asset tasks panel, and then upload.
  2. Ensure your image is power of 2 resolution, like 64, 128, 256, 512, 1024 or any other ^2.
1 Like