Playcanvas-sync .pcconfig woes

I’m having trouble setting up playcanvas-sync. When I try any of the commands (pcwatch, etc) I get the following error:

Error: could not find target directory: . Check capitalization.

My .pcconifg is set up like this:

“PLAYCANVAS_BRANCH_ID”: “my-branch-id”,
“PLAYCANVAS_PROJECT_ID”: my-project-id,
“PLAYCANVAS_TARGET_DIR”: “/Users/jlanis/playcanvas-test”,
“PLAYCANVAS_API_KEY”: “my-app-key”,

my folders are setup like this:

— playcanvas-sync
— playcanvas-test

I’ve tried placing .pcconfig in my home directory, my project directory, and even in the playcanvas-sync directory. Nothing works. It seems as if .pcconfig is not even getting found, since I have PLAYCAVNAS_VERBOSE enabled and that’s not working, either. I’ve also tried using pcconfig.json in the project directory. Any suggestions would be helpful.

The target dir should be relative to config file. You can check an example in this thread:

1 Like

OK, well, I managed to get it working on my other computer. Not sure what the issue was but will try reinstalling playcanvas-sync