Particle system still active after deletion [SOLVED]

If I add a standard particle system, move it to another location and click the ‘launch’ button In the editor, I see TWO active particle systems. But not in the editor. And if I delete the particle system, there is no particle system left in the editor, but there is still one in the preview (after clicking the ‘launch’ button).
The ‘ghost’ particle system that is still active is located at the default position.
The browser I use is Firefox.
Is this a bug?

Can you guys at least confirm this is happening? Or do you need more clarification?

Tried to repo this in PlayCanvas with a blank project with no success.

  1. New project
  2. Create a particle system
  3. Move it (some particles are left over in the preview at the old location. After the lifetime ends, they disappear).
  4. Press launch button
  5. Only one particle system is seen

Thanks for testing it yaustar. It’s weird that it is not reproducible. In my case the particles at the old location still emits particles (forever) :thinking:

Maybe post a link to a public project which shows the problem? Then other devs can try it quickly, and confirm whether or not they are seeing the same problem

Good Idea Mal_Duffin.
Here it is:
There is no Particle System, and yet, when you preview it, there is a particle system emitting particles.

WTF. O.o Not sure how that happens. Can you repo this from a brand new project?

No, I cannot reproduce this from a brand new project.
Do you notice that you cannot activate the debug console (F12) in the preview?
(update) I see the problem: The Root has a Particle System as a component :rofl:

1 Like

Lol, that was the one entity I didn’t have a proper look at :rofl: