Particle System 'autoPlay' not working?

I created an entity with a a particle system and UNchecked ‘autoPlay’. However, the particles start playing when I launch the game regardless. I noticed in the api there is no property for ‘autoPlay’ so wondering if it’s just ignored. Is it used? Or do I need to make sure to stop the particle system in code when the game starts?


Hi Rich,

It looks like a bug, if you disable “loop” and “auto play” then the particle system doesn’t start as expected.

I’ll look into it, but I don’t think loop should affect auto play.