Particle effects on 2D screen

Hey guys,

I cant seem to place a particle system on the UI screen i.e on top of a 2D UI element,
Any help would be appreciated!


Unfortunately. I don’t think it’s a supported feature yet :frowning:

1 Like

It’s not supported much, but I’ve done this few weeks ago and that worked pretty well.

Create new layer, call it “UI FX”. Create new camera, call it “Camera FX”. Set up this camera to use this new layer, and add the layer to render after default “UI” layer. Then create Particle System, and add it to this layer, and position it so that the “Camera FX” can see it. This makes the Particle System to render on top of UI.



I followed the same steps, but didnt get the result…regarding the Camera FX, what should be its priority? because atm it overrides my main camera.

I’ve tested it in this fork before and it still works, have a look

There’s “ParticleSystem” in the scene that renders on top of the UI, using “UI FX” Layer which uses “Camera Top”. Note that the camera was added to render after UI in Render Order section of Settings.

1 Like