Mesh collision problems

I’ve added mesh collision to some entities and they work fine no problem at all, but when i up the speed on my character he just phases straight through the building and other objects is there something that can help with this?

Hi @Ehsaan_Khan,

You may have to enable continuous collision detection for your fast moving objects:

I don’t understand how this works i added it to my character and it still phases through objects. Is there a specfic type of number i need to input for it to work?