Material doesn't reflect light in play mode

Hi! I have a material that doesn’t take the light in the play mode(second image), but it does in edit mode(first image).

link to editor:

Any ideas about why that happens or how to solve it?

Thank you!

Hi @sorina.designora,

It may be something with the lightmaps, if you rebake the lightmaps in editor, do you still see a difference?


@mvaligursky any idea?

1 Like

Thanks for the quick response, @Leonidas!

I turned on and off the autorebake, now they’re all on;
I also enabled and disabled the lights, nothing changed;
What’s also interesting is that 2 out of 3 paintings have this problem, but all have the same material settings and they all used to work well. The bedroom one doesn’t have this issue.

If you have any work-around, i’m open :smiley:

I haven’t checked your project, as it looks like a large size to load. A lightmapper only affects the models that are marked as Lightmapped in their properties. So, make sure you have that one checked on your painting. Mark your static models as Static too. Alternatively, you could bake the lightmap in your modelling software, instead of relying on the PlayCanvas version.

1 Like

Was this solved? I tried running the project and get some script error and the camera is in the corridor outside of that room from the screenshot, but it seems it’s getting lit?

If the problem persist, could you please try and create a simple test project showing this issue … just a single wall, picture, light, camera … that kind of thing, so that we could investigate?

1 Like

@mvaligursky When the app is launched and the user walks (using FPS controls) to the painting, it looks like this:

In the Editor, it looks like this: