Locally hosted content results in a black screen :(

Hi all,

I’m building some content at the moment using Articulate Storyline (SL), and with that I’m embedding PlayCanvas material inside to interact with. Unfortunately, things seem to be broken now.

I published sometime last week or the week before and I had to resort to a very early build from the publish options, however, that publish option has now been discarded. With that, I’ve tried all publishing options and none of the content now run locally, they are fine if published to an FTP site.

But I do need the option of exporting and embedding the content in SL. Anyone know how to fix this, or is this an engine version problem that has been overlooked?

Cheers for any feedback


What browser are you using? Firefox has a black screen bug (the engine has a workaround in the latest release).

Firefox seems to be the best option for local playback, in order I use:


Chrome and Edge never worked, but Firefox used to, that is until now. I’m sure my FF is up to date.


WEBGL_debug_renderer_info is deprecated in Firefox and will be removed. Please use RENDERER.

I’m up to date with 120.0.1.

See the section Running a Downloaded Build - are you doing when running locally?


Hmmm, that is fine but it used to work with previous build versions, and now I have a dilemma of the content not working as an embedded Web Object inside SL.

Is there any way to roll back to a previous compile, or do we only have 3 options given to us at a time?

The engine your project uses is embedded in the zip file you get when you download a published build. You can replace it by different version if you wish (as long as the code you write is compatible with it).

You can download older version here, for example: https://code.playcanvas.com/playcanvas-1.65.0.js

And that there has resolved my issue for a locally built application, that build is probably the one I was last using and is now working again.

Many thanks for the help


If 1.65 is what you need, try and use its last patch version have all the fixes, in this case

Hmmm, so another day on and this hasn’t been resolved. I’ve started doing any web dev type work on my laptop instead of my 3D workstation. As a result, what I published yesterday on the desktop worked by copying the 1.65 stable-min.js script over the downloaded and published content on my device.

Today, working on the laptop, the result I was seeing yesterday isn’t working. Whether that’s to do with the fact I’m now using Win 11 instead of Win 10 Ultimate? Does that make a difference? I’m still using the same Firefox browser with the latest updates, but that again doesn’t work on the laptop.

Is there anything else that could be at fault, I will most likely launch the workstation tomorrow to make sure that it still works with the method of download/patch later.

Just wondered if I’m doing some stupid user error!?



I’d suggest to follow this.

Please note, the bug in Firefox I mentioned is not fixed yet. They will presumably fix it in version 121. The engine just disables some settings, if it detects Firefox currently.

As much as I’d love to, the problem comes when publishing a storyline Web Object, that is a file based system by the way it compiles it’s code for any SCORM compliant course.

I’ll follow this up tomorrow now, and go back to my workstation to see if it is still working, but as of yesterday it was resolved. Fingers crossed it is just a problem with the method on my laptop.

Wow, so I decided to go to the workstation and everything works as should, I copy over the 1.65.0 js file and it launches all well and good.

Now I’ve got to figure out why this doesn’t work on the Win 11 Laptop. Any ideas?

I’m running all content on a mapped network (NAS) drive and it def works on Win 10 Ultimate, as opposed to Win 11 (I think Home).

I’m just so glad it works as it should, even the compiled SCORM file works as it should, but on Win 11 it doesn’t. Odd.