Issue with importing models

Hello, guys,

I am relatively new to the PlayCanvas framework having played with it in the last 2 weeks.
So my problem is this:
I imported a .fbx model, exported it using the “Export Model Archive” option to .json and then tried to load it in my app using the loadFromUrl function. The callback passed to loadFromUrl is never called and the model is not shown in my app (everything fails silently). The same model is visible in the online editor @

I have pulled the latest version of PlayCanvas from github and have built it.

By the way, when I:

  • start a local HTTP server in the folder of your repository on my machine
  • try to access the examples/load Model section
    the model is not shown as well, so I guess there is an issue indeed.

Any ideas?

Thanks in advance.

Kind regards,
Trifon Statkov

I can confirm this. Just grabbed the latest version from github and the callback isn’t running.
They changed the file format for materials a few weeks back, so maybe they’re playing with the model file format.

If you want a working build, I’ve got one up here:
It’s about 3 weeks old.

1 Like

Looks like a combination of a change to the asset loading and a bug with with material loader caused this.

There is a fix in default branch.

1 Like

Yup, that fixed it. Thanks.
I am always amazed by the responsiveness of your guys bug fixing.


Never good to have a buggy engine :slight_smile: