Interpolation in animations is always linear

Is there a way to specify the animation interpolation for bones?

I’m trying to use some bones in blender to specify the UV to display, and I need constant interpolation with no in-betweens. But, even if I use constant interpolation in blender, the result seems like having 2 or 3 frames of interpolation. I noticed that the JSON of animation has each keyframe 10fps and it seems the interpolation appears between frames 9 and 10.

Hmm, from what I know there isn’t a setting exposed for that, though I may be wrong. There is currently a lot of work on upgrading the animation system.

Try raising an issue about it in the engine repo.

You may have to cheat and add a keyframe just before the one ‘moves’

1 Like

Guess I’ll play around this idea.