Inconsistent UV Seam Issue

Hey all,

I’ve got an odd issue near some UV seams on my character. I unwrapped it myself and can verify that the uvs do not overlap. Here is what it looks like:

The issue is the small white line on his torso and on the backs of his shoes. I have noticed that this issue does not pop up if I play on my iPhone (could that be because of the different screen resolution?). It also never showed up in Substance painter when I was texturing the model. It only shows up in PlayCanvas. Could it have to do with the resolution of the maps? (512x512) Using linear or point filtering on my maps makes no difference. Cranking up the Anisotropy does help but it doesn’t make it completely disappear.

Let me know if anyone has any thoughts on this.

Hi, on the texture, can you try to set the UV address to clamp, and see if it fixes the issue?
Screenshot 2022-02-01 214607

@Saad_Haider I should have mentioned that in the original post, my bad. I have also tried all different settings on the Address slots and it has not fixed it. It is on clamp in that screenshot. Thanks for getting back to me.

Can you share a repro in a project with that model?

Yes one sec.

@Saad_Haider I actually can’t reproduce it lol. I tried using the model viewer template and couldn’t reproduce it so I took my project and gutted it and then couldn’t reproduce it that way either. I think it has to do with the distance of the camera from the character/ the scale of my scene because if I move my camera close to the character, the seams disappear. Do you have any thoughts on that?

@Saad_Haider Oh I figured it out… If I turn off frustum culling it goes away in my project. That’s not very good for performance though.

hm that’s pretty weird, @yaustar any thoughts?

Would you be able to share a repro of the issue?

Does it also occur in the previous version of the engine (1.50.2)

@yaustar I know I probably sound crazy but I actually can’t reproduce it at all now. I flicked frustum culling off and it went away. To my knowledge, I changed literally nothing else about the project. Now when I turn it back on, it remains fixed. Very odd. Nevertheless, the issue is gone. Should I just chalk this up to WebGL craziness? Does it cache things on your machine between refreshes of a WebGL enabled page?

Errr… No idea tbh. If you do see it again, whip up a repro (if possible) and we try to take a quick look


@yaustar @Saad_Haider
Very weird. Thanks guys :+1: