Importing model from Maya is causing strange, distorted model behaviour
sorry I can’t embed images yet.

Here is my model, it appears in Unity and Maya just fine, but importing into Playcanvas makes the model strangely distorted and the skeleton is completely different. Tried reimporting many times, lots of different export settings in maya and have tried a few different models that I made in maya, all have similar issues even though the rigs and skeletons are completely different. What could be going wrong here?

I am thinking this is some kind of issue with the export settings that playcanvas does not like.

Hi @graeme_Judkins and welcome,

It looks strange even in Blender, not sure if this is just a PlayCanvas issue.

Hmm, FBX Review looks fine :thinking:

I think it’s because you have non unique named nodes for the rig. It’s something that we and some other importers don’t handle that well. FBX format requires node names to be unique IIRC.

Try making each node name unique and try importing again please

Thanks everyone, I will try the fix that yaustar suggested and let you know how it turned out!

I added a new model with the rig nodes renamed to all be unique, It behaves the same way. I have added it to the dropbox archive as well.

I’ve created a ticket for this as I’m not sure what the issue is: Imported FBX rig/mesh is not correct/distorted · Issue #985 · playcanvas/editor · GitHub

@slimbuck Any ideas on this one?

Hi @graeme_Judkins ,

What is strange is that every node in the hierarchy has a scaling value. The scaling shouldn’t be there and results in the distorted hierarchy you see and so strange skinning on the mesh.

I went through all the nodes and reset scale, it looks a little better now:

TBH I’m not really sure why FBX review -doesn’t- have this issue and I’m not sure what we can do about it on our end, but I will investigate further.

Until then, if you can somehow get rid of the scaling on all nodes that would probably solve your problem for now.


Hey guys, thanks for looking into this.

We found a solution to this issue:

It was because when we exported the model, the scale was not in cm, so the result was that the hierarchy of bones got smaller and smaller as you went down the chain, eventually the last node was tiny. The model allegedly working in Unity was a red herring, it didn’t animate correctly there; the skeleton wasn’t working there for a different reason.
We re-exported with the cm scale and it’s working great now.

Could we perhaps add something to the docs about export settings like what Unity does in their docs here?: Unity - Manual: Preparing Assets for Unity

1 Like

What were the previous export settings using? Feet? I’m not too familiar with Maya unfortunately

We were using inches for export

1 Like