Imported mixamo FBX doesnt show in playcanvas

I just uploaded an FBX file exported from Mixamo, as shown in this project.

I tried using the FBX version and Template version of the model and nothing shows.

Please let me know what I am doing wrong.

The model loads, but is very small:

Consider either resizing it in a 3D model program or increasing the scale of the template from 0.01 to 1.0 on all three axes.

Thank you!
Now I see that the template imports the mixamo model as Render not as Model. So mixamo.glb animation file cannot be used at all because Render requires Anim, which doesnt work with the mixamo.glb.

I tried adding the GLB version but that cannot be added to any entity.

So how do I make the animation work for this mixamo model?

Hi @metame and welcome!

Maybe you can try to use the animation component on the entity of the animated root bone.

Is there a reason why you can’t use the new anim component?

Mixamo only provides animation file, not anim file. tried adding animation to hips and that didnt animate either

Both components use the same file. Despite this, the old animation component doesn’t seem to work here. Fortunately, the new anim component works as expected. Below the project with a working setup.

1 Like

thank you!!