How to select an asset for "renderer" component in Editor

I’m not able to select any of my *.glb or *.fbx as an asset for RENDERER component in Editor. They just dissapear when I try to select the asset. No problems with MODEL compomenent which is now marked as “legacy”.

Can anyone help me? Thanks.

When you import an fbx file into the Editor, a glb file is created, and also one or multiple render assets. You need to connect render assets to the render component, not the glb itself.

Also, a template file is created, which already contains render components set up and connected in the hierarchy. You can simply drag & drop that into the scene.

1 Like

Unfortunatelly no render assets are created, just glb (and original fbx).


Enable the “Import Hierarchy” to use Render component.
If this is disabled, the created model needs a Model component.


Thank you :slight_smile: