How to remove visual artifacts visible in 3d text?

I use a 3D text (by using 3D screen entity) and at some distance, I can see visual artifacts in the text. In this example, we can see vertical line. If I change the text color, theses artifacts will change too.

If I move the camera closer, this problem goes away:


It is similar when using the outline. Here the same black outline but at different distance:

Is there a way to avoid that? I tried playing with the scale and the font-size but I can’t see any difference.

Hi @Mystik,

Can you try increasing the camera near clip plane distance and decreasing the far plane as well?

E.g. 1/100

See if that makes any difference.

1 Like

It feels like perhaps the font texture has mipmaps generated … when camera moves away, a mipmap is used and you get those bleeding edges. See if there’s a way to turn off the mipmaps.